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Introducing BlackBerry Workspaces 
for Windows

BlackBerry Workspaces for Windows enables you to easily and intuitively sync and share your folders and files to collaborate 
with other users directly from your PC.

Installing Workspaces for Windows creates a Workspaces Folder on your PC from where you can manage your files in 
workspaces and subfolders, just as with any folder on your computer. The Workspaces Folder is automatically synced with the 
Workspaces server and can be accessed from the Workspaces Web Application and on any other devices where you have 
Workspaces installed.

The Workspaces Folder contains workspaces which are folders that you create or that are shared with you by other users. If you 
are a workspace owner, you are also assigned a personal workspace when you first sync with the Workspaces Web Application. 
When using the "move to Workspaces" command, folders and files are automatically placed in your personal folder, called My 
Workspace.

Share your workspaces with other users. New files and changes you or other users make in a shared workspace are 
automatically updated to all the members of this workspace.

Use Workspaces advanced features to restore changes, recover deleted files, and assign user roles (such as Contributor with 
permissions to share file changes, or as Visitor without permissions to share changes).

View tracked information of user activities affecting the files in your workspaces.

View Workspaces-secured files in Adobe Reader or Microsoft Office

Workspaces for Windows includes plugins for Microsoft Office 2003-2013, Adobe Acrobat (versions 8 thru 11), and Adobe 
Reader (versions 8 thru 11), that enable you to work with Workspaces-controlled documents from within these applications.

Send files and collaborate securely from Microsoft Outlook

Workspaces for Windows includes a plugin for Microsoft Outlook that can protect attachments in outgoing emails. When you 
choose to protect your attachments, Workspaces replaces the attachment with a link from where the file can be downloaded, 
and uploads, encrypts, and stores the file on the Workspaces server.

Enable collaboration to allow your recipients to work on shared files and track any actions made on the file directly within 
Outlook.

Note: Microsoft Outlook versions 2010, 2013, and 2016 are supported.
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Getting Started

Setting up and installing BlackBerry Workspaces 
for Windows
Download and install BlackBerry Workspaces for Windows.

After the installation, BlackBerry Workspaces creates a Workspaces Folder in your Windows Explorer, a shortcut to the 
Workspaces Folder on your desktop, and a Workspaces icon in the system tray, through which you can perform various 
Workspaces-related actions.

Signing in to BlackBerry Workspaces for 
Windows
After installation, you are prompted to sign in to Workspaces. Sign in by the relevant method as set by your organization, see:

• Signing in using your email account

• Signing in with username and password

Signing in using your email account
Follow these steps if your organization is configured for email authentication.

1. Right-click the Workspaces icon in the taskbar, and select Sign In.

2. In the Email box, enter your email address.

3. In the Site box, enter the URL provided by your Workspaces Organization Administrator; otherwise leave it with the preset 
default value.

4. Click Sign in. An authentication email is sent to the email address supplied.

2
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5. Open this email in your regular email, copy the verification code, and return to the sign-in screen.

6. Enter the verification code.

7. You are signed in.

8. Click OK.
The Preferences window opens on the Workspaces tab.

9. Select the workspaces that you want to sync to your computer and click OK. For more information, see Managing synced 
workspaces.

After you finish: 

Note: If your network uses a proxy, this will have to be configured. For more information, see Configuring proxy settings.

Sign in with username and password
Follow these steps to authenticate if your organization is configured for sign in by username and password.

1. Right-click the Workspaces icon in the taskbar, and select Sign In.

2. In the Email box, enter your email address.

3. In the Site box, enter the URL provided by your Workspaces Organization Administrator; otherwise leave it with the preset 
default value.

4. Click Sign in.

5. Enter your email address and password.

6. Click Sign in.
The Preferences window opens on the Workspaces tab.

7. Select the workspaces that you want to sync to your computer and click OK. For more information, see Managing synced 
workspaces.

After you finish: 

Note: If your network uses a proxy, this will have to be configured. For more information, see Configuring proxy settings.

Sign out
1. Right-click the Workspaces icon in the taskbar, and select Preferences.

2. Click the My account tab.

3. Do one of the following:

• To sign out of one account, next to the account that you want to sign out of, click Sign out.
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• To sign out of all of your accounts, click Sign out of all accounts.

The Workspaces Folder, and all workspaces and files in it, are removed from your computer. The workspaces and files 
remain on the Workspaces server, and are restored to the desktop Workspaces Folder when you sign in again using this 
user account.

Add a new account
Add an account to authenticate additional Workspaces accounts on your PC.

1. Right-click the Workspaces icon in the taskbar, and select Preferences.

2. Access the My account tab. The Accounts area displays a list of accounts you use to sign in to Workspaces. Workspaces 
synchronizes the files if the sync account to the Workspaces Folder. You can open files that were sent to any of your 
Workspaces accounts, provided you are signed in to the account.

3. Click Add account.

4. Sign in to Workspaces with your email or username and password. See Signing in to BlackBerry Workspaces for Windows 
for more information. Once you have completed the sign in process, a confirmation message is displayed.

5. Click Finish.
The account is added.

6. To download and open files shared via Workspaces on this account on your PC, click Set as sync account.

7. Click OK to close the Preferences window.
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Managing settings

Manage your Workspaces for Windows settings in the Preferences window:

• Decide how to work with Workspaces-protected documents in Microsoft Office, turn on the ability to protect 
attachments in Microsoft Outlook, and set how Workspaces-protected PDF files are opened. For more information, 
see Enable plugins.

• If applicable, configure your proxy server settings. For more information, see Configure network settings.

Enable plugins
1. Right-click the Workspaces icon in the taskbar, and select Preferences.

2. Access the Plugins tab.

3. To turn on Workspaces for Microsoft Outlook, select Protect files you send from Microsoft Outlook with Workspaces.

For information on configuring the plugin, see Configure Workspaces for Microsoft Outlook.

4. In the Work with Workspaces-protected PDF documents area, click Set Workspaces Viewer as default to set the default 
program to use when opening Workspaces-protected PDF files to the Workspaces Viewer.

5. Click Apply.

Configure network settings
Before you begin: If your network uses a proxy, configure the proxy settings in order to work with Workspaces, and enhance 
performance by adjusting your bandwidth settings.

1. Right-click the Workspaces icon in the taskbar, and select Preferences.

2. Select the Network settings tab.

3. To set Workspaces app for Windows to automatically detect your proxy settings, select Auto-detect.

4. To set specific proxy settings, select Use the following proxy settings and enter the URL and port number of the proxy 
server.

5. If authentication details are also required for your server, select Proxy requires authentication, and enter the username 
and password.

3
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Note: If your Windows network settings use an automatic configuration script, you can leave out the proxy details, and they 
will be set by script.

6. To limit the download rate, select Limit download rate to and enter the desired limit in kilobytes per second.

7. To limit the upload rate, select Limit upload rate to and enter the desired limit in kilobytes per second.

8. Click Apply.

9. If the credentials are incorrect or missing, you are prompted to enter your credentials.

Managing settings
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Working with workspaces

Workspaces are folders that you create or that are shared with you. Workspaces can contain folders and files. Use workspaces 
to manage your documents.

Accessing the Workspaces Folder
• Right-click the Workspaces icon in the taskbar, and select Workspaces folder.

Access your workspaces and any files they contain as you would a regular folder.

About workspace types and roles

If you are a workspace owner, a personal workspace named My Workspace is created for you following your first sync. Your 
personal workspace is the default folder for files that you move to the Workspaces Folder using the "Move to My Workspace" 
command, and for files that you drag to the Workspaces root folder.

Your personal workspace is marked with the following icon:

Workspace icons show the workspace type, as shown in the following table:

Workspace type Icon

Workspaces workspace

Windows Files Share workspace

SharePoint workspace

4
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About workspace status

Small overlay icons at the bottom left corner of the workspace, folder, or file icons indicate the status of synchronization.

Icon Description

The item has synced.

The item is syncing (files are being uploaded or downloaded).

This item has a sync error.

If there is no overlay icon, it can indicate that there is currently no connection with the Workspaces server, or that the folder has 
not been synced.

Annotations

If you are adding the folder to Workspaces, you can sync the folder in order to create a workspace on the server. See Managing 
synced workspaces.

The following icon indicates that a file has annotations:

Annotations can be viewed by opening the file in the Workspaces PDF Viewer. See Open files in Workspaces Viewer for more 
information.

Syncing workspaces
Manage your synced workspaces, check the sync status and troubleshoot any errors. Pause sync if necessary, and re-sync a 
workspace.

Switch accounts
1. Right-click the Workspaces icon in the taskbar, and select Switch sync account.
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2. Choose the account that you want to set as the current sync account.

Note: If you do not see the account that you want, click Manage accounts, and add the account.

3. Click OK.

4. The account you selected is set as the sync account. If you have already worked with this account, your account 
workspaces are synced to your computer. If this is the first time you are using the selected account, you are prompted to 
select which of your account

Tip: You can also switch accounts in the Preferences window My account tab: click Set as sync account next to the 
desired account.

Manage synced workspaces
Before you begin: After signing in, you are prompted to select workspaces to synchronize to the Workspaces Folder. 
Workspaces downloads these workspaces and any files they contain into your Workspaces Folder. Thereafter, manage the 
workspaces you want to sync on your computer by selecting them in the Preferences window Workspaces tab. All selected 
workspaces are continuously synced.

Note: 

If you "delete" a workspace by right-clicking the workspace and selecting Delete, this action removes the workspace from the 
synced workspaces list only, i.e, the workspace is removed from your Workspaces Folder, but not from the Workspaces server. 
To restore the workspace, select the workspace in the Synced Workspaces window.

If you delete a folder (within a workspace) by right-clicking it and selecting Delete, the folder is removed from your Workspaces 
Folder, and from the Workspaces server. To restore it, use Workspaces Web Application.

1. Right-click the Workspaces icon in the taskbar, and select Preferences.

2. In the Preferences dialog box, select the Workspaces tab.

3. Add or remove workspaces that you want to sync.

If you select additional workspaces, Workspaces downloads them into the Workspaces Folder.

If you clear a workspace in the list, it is deleted from the Workspaces Folder and is no longer synced. Your selection is 
remembered the next time you log in and in subsequent application upgrades.

Note: 

If you have a shared workspace with the identical name as one of your local workspaces, upon sync, the shared workspace 
is named with the suffix Created By<xxx>.

Not all files and folders can be synced with the Workspaces server. Some file types are not supported, and in addition, your 
organization administrator may prevent some file types from syncing with Workspaces. Hidden files and folders are not 
synced. If you encounter problems syncing files or folders, contact your administrator.

4. Click Apply.
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Tip: Use the arrows to sort the Workspaces and Roles columns alphabetically.

Sync new workspaces
If you are invited to a new workspace, a notification appears in the taskbar, or go to the Preferences window Workspaces tab to 
see new shared workspaces.

1. Click the popup message.

2. Select the shared workspace(s) that you want to sync, and click Apply.

After you finish: 

Note: If you have a shared workspace with the identical name as one of your local workspaces, upon sync, the shared 
workspace is named with the suffix Created By<xxx>.

View a list of sync errors
Before you begin: If there was a problem syncing your files, an item appears in the taskbar menu.

1. Right-click the Workspaces icon in the taskbar, and select x Sync error(s). The Workspaces Sync Errors window appears.

2. Click the file name to locate the file.

3. If available, click the suggested solution to solve the issue.

4. Click  to view more information about the error and the suggested solution. 

5. Follow the instructions in the solution to remove the error.

Check sync status
Check the sync status to view which files are currently being synced, uploaded, or downloaded.

Right-click the Workspaces icon in the taskbar, and select the dynamic sync progress menu item, for example, "31 files, 36MB 
left".
A window opens showing the files waiting to be downloaded or uploaded.

Pause and resume sync
Pause sync activity between your Workspaces Folder and the Workspaces server to save system resources.

Right-click the Workspaces icon in the taskbar, and select Pause sync.

After you finish: Right-click the Workspaces icon in the taskbar, and select Resume sync.
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Re-sync a workspace
Before you begin: Force a workspace to re-sync with the Workspaces server to ensure that the local workspace is up to date.

This is useful, for example, to restore a file that you deleted from the Workspaces Folder where you do not have sufficient rights 
to remove it from the workspace. By re-syncing the workspace, the file is restored to your local Workspaces Folder.

1. Right-click the workspace folder and select Workspaces > Re-sync.
A confirmation message appears.

2. Click Yes.
The workspace is re-synced.

Share a workspace or folder
Workspace administrators can share their workspaces with other users.

Note: Workspaces are folders located directly under the Workspaces Folder. Workspaces can contain folders, but folders cannot 
be shared separately.

1. Right-click the workspace folder and select Workspaces > Share.
The Share Workspace window appears.

2. In the Add members area, enter the email addresses of users you want to share the workspace with.

3. In the Personal message box, enter a message (optional).

4. In the Roles list, select the role that you want to assign to the members you are adding. For more information, see About 
roles.

5. In the Permission list, select the user access rights for the workspace. For more information see About permissions.

6. In the Watermark list, set whether workspace PDF files are displayed with a watermark.

7. In the File expiration list, set the time when the file will no longer be accessible by the recipients. Select a specific date, a 
time period from the list, or never.

If you select Specific date, click the calendar icon and choose the desired date from the calendar.

8. Click Share.

Copy the link to a workspace, folder, or file
Copy the link to a synced workspace, folder, or file, to share the link with users that have permission to the workspace.

1. Right-click a synced workspace, folder, or file, and select Workspaces > Copy link.
A balloon notification appears informing you that a link was copied.
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Note: Click the balloon to follow the link to the item in the Workspaces Web Application.

2. Paste the link into an email and send the mail.
The link is sent to the recipient. Recipients can access the workspace if they already have access to the workspace. If you 
wish to share the workspace with a new user, see Sharing workspaces.

Move and copy folders and files to the 
Workspaces Folder
Note: You must be a workspace owner to perform this action.

Use the Workspaces context menu to move folders and files that you want to sync into the Workspaces Folder in order to 
streamline your workflow. When working on the sync folder drive, you can move folders and files to Workspaces; when working 
on other drives, you can copy folders and files.

Move a folder and its contents to the Workspaces Folder
• Right-click the folder that you want to sync, and select Workspaces > Move & create new workspace(from the sync 

folder drive), or Copy & create new workspace (other drives).
The folder is moved or copied to your personal workspace in the Workspaces Folder, and the folder is synced.

Move a folder and its contents to the Workspaces Folder, and 
share the workspace
1. Right-click the folder that you want to sync, and select Workspaces > Move & create new workspace and share (from the 

sync folder drive), or Copy & create new workspace and share(other drives).

2. In the Add members area, enter the email addresses of users you want to share the workspace with.

3. In the Personal message box, enter a message (optional).

4. In the Roles list, select the role that you want to assign to the members you are adding. For more information, see About 
roles.

5. In the Permission list, select the user access rights for the workspace. For more information see About permissions.

6. In the Watermark list, set whether workspace PDF files are displayed with a watermark.

7. In the File expiration list, set the time when the file will no longer be accessible by the recipients. Select a specific date, a 
time period from the list, or never.

If you select Specific date, click The calendar icon and choose the desired date from the calendar.
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8. Click Share.
The folder is moved or copied to your personal workspace in the Workspaces Folder, and your folder is synced. When the 
folder is moved or copied, a confirmation message appears in the Move to WatchDox & Share Workspace dialog.

9. Click Close.

Move files
Use Workspaces for Windows to upload files of up to 10GB. Move files on your sync folder drive to Workspaces, or copy files 
from other drives.

1. Right-click the file that you want to sync.

2. In the menu, select Workspaces > Move to My Workspace (from the sync folder drive), or Copy to My Workspace (other 
drives).
The file is moved to your personal folder in the Workspaces Folder, and the folder is synced.

View sync details
View sync information and your capabilities for any workspace, folder, or file in your Workspaces Folder.

Right-click a workspace, folder, or file, and select Sync details.
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Working with files

Upload a file
Drop a file on a synced workspace or file to upload it to that location. Use the Upload to Workspace command to upload one or 
more files to any non-synced workspace or folder where you have upload permissions.

1. Right-click the file that you want to upload to a non-synced workspace or folder, and select Workspace > Upload to 
Workspace.

2. In the Upload to Workspace dialog, browse to and select the target location for the file.

3. Click Upload.
The file is copied and uploaded.

Locking files
Lock a file to prevent other users from uploading a new version for 24 hours. This feature is enabled by orgaizational policy.

File lock is available in organizations when enabled as a file policy and can be executed by workspace administrators, 
contributors,and users with a customized role with update abilities.

Locking files

Files are locked using the locking action only; opening or editing a file does not lock the file. If you lock a file while another user 
is working in the same file, they receive a notification in the open file. If they save the file after you locked it, their file is saved as 
a conflicted copy.

Unlocking files

Once locked, files are locked for a default of 24 hours after which time the file is automatically released. Files can be unlocked 
at any time by the person who locked the file or by a workspace administrator. An email notification is sent to the locking user 
when the lock expires or when the file was unlocked by an administrator. If your account is deleted from your organization, your 
locked files are automatically released.

Lock a file
• Do one of the following:

• From Windows Explorer, right-click the file that you want to lock, and select Workpsaces > Lock . To release 
the file: right-click the file and select Workspaces > Unlock .
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• When working on an Office file, locate the Workspaces ribbon in the Home tab and click Lock file.

The file is locked for 24 hours, and during that time can only be unlocked by yourself or a workspace administrator. 
After that time, the lock is automatically removed.

Unlock a file
Locked files are marked with .

You can unlock a file:

• If you locked the file.

• If you are a workspace administrator.

• Do one of the following:

• From Windows Explorer, right-click the file and select Workspaces > Unlock .

• When working on a protected Office file, locate the Workspaces ribbon in the Home tab and click Unlock 
file.

Open a protected document
1. Open the protected document in the usual way.

When opening protected Office documents in your Workspaces for Windows workspaces, you may be required to sign in to 
Workspaces. If you are asked to sign in, follow the steps below.

Note: The sign in method may differ depending on your organization's configuration.

2. When the sign in dialog appears, enter your credentials, and click Sign in.
A Microsoft message appears warning you that you are attempting to send information to an Internet site that is not in your 
trusted zones.

3. Click Yes.

4. If you do not want to see this message again while working on this server, click Don't show this message again.
The document opens.

View a list of recently updated files
View a list of recently updated files in your Workspaces folders.
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1. Right-click the Workspaces icon in the taskbar, and select Recently updated files.

2. Select a file in the submenu to open the containing folder in an explorer window with the file selected.

Manage permissions for sent files
Manage permissions for your sent files in the Workspaces Web Application.

1. Access and sign in to the Workspaces Web Application.

2. Go to  > Sent items. 

3. Select the sent item that you want to manage permissions for, and access the Permissions tab.

4. Change the current permissions per user, revoke the permissions, or add new users by forwarding the file, as desired.

After you finish: For more information, refer to the Workspaces Web Application User Guide.

Track file activity
View a map tracking user activity related to the selected file (including user email address, activity, date and time, and site 
location - city/state/country) for files in workspaces where you are administrator.

The activity log shows details regarding activities performed on the selected file.

1. Right-click the file and select Workspaces > Track activity.
A page opens in your browser showing the last activity done by each user on this file along with a map showing where the 
activities took place according to IP geo-location.

2. Click Full Log on this page to view the full list of all the users’ activities.

3. Click the heading of any column to sort the log by that column.

4. Hover your mouse over an activity to view more details.

Restore deleted items
Restore deleted folders and files from the Workspaces Web Application. When you delete a file or a folder that you have the 
necessary permissions to delete in a synced workspace or a workspace itself, it is moved to the Recycle bin. To restore a deleted 
workspace, contact your administrator.

Note: 
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If you "delete" a workspace by right-clicking the workspace and selecting Delete, this action removes the workspace from the 
synced workspaces list only, i.e, the workspace is removed from your Workspaces Folder, but not from the Workspaces server. 
To restore the workspace, select the workspace in the Synced Workspaces window.

If you delete a folder (within a workspace) by right-clicking it and selecting Delete, the folder is removed from your Workspaces 
Folder, and from the Workspaces server. To restore it, use Workspaces Web Application.

1. Access and sign in to the Workspaces Web Application.

2. In the location from where you deleted the item (Workspaces, Inbox, or Sent items), click Recycle bin in the info panel.

3. Hover over the folder or file that you want to restore, and click Restore. The selected file is restored and appears in the 
location from which it was deleted.

Tip: To permanently delete the item, click Delete.

Working with Workspaces Viewer
Use Workspaces Viewer to open protected files and to review and create annotations created in Workspaces.

Open files in Workspaces Viewer
• Do one of the following:

• Double-click a protected PDF file.

• Right-click a file, and select Workspaces > Annotate .

• Right-click a file with annotations, and select Workspaces > View annotations .

Note: Any changes that you make to the annotations in the file are saved when closing the viewer and synced with the 
Workspaces server.

Common actions in Workspaces Viewer
Use the icons on the toolbar to do the following:

Icon Description

Print file

Send a copy (see Send a protected file) or share annotations (see Share annotations)
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Icon Description

Search within the file

View actual size

View at full size

Fit the file to the width of the viewer

Rotate clockwise by 90 degrees

Rotate anti-clockwise by 90 degrees

Zoom out

Zoom in

Choose the magnification

Enter the desired page number to go to that page

View annotations (for more information, refer to the following sections)

View information to see your permissions

Use the free draw tool
1. Click  to open the annotation menu. 

2.
Click the down arrow next to the marker tool , and do one of the following:

• To change the color, select the desired color.

• To change the marker tip size, select the desired thickness.
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• To change the transparency of the marker, select the desired transparency.

The tool changes according to your selection. To change another attribute, repeat this step.

3. Draw on the file as desired.
The annotation is saved automatically.

4. To change the color, thickness, or transparency of the line after drawing, select the drawing and repeat step 2, changing 
the attributes as desired.

5. To move the drawing, drag it to the desired location.

6. To delete the drawing, select and delete it within the editor, or from the annotation management pane, click  > Delete.

Highlight text
1. Click  to open the annotation menu. 

2. Click the down arrow next to , and choose the highlighter color.

3. Highlight the desired text.
The annotation is saved automatically.

4. To change the color of the highlighted text, select the highlight and repeat step 2.

5. To delete the highlight, select and delete it within the editor, or from the annotation management pane, click  > Delete.

Add a sticky note
1. Click  to open the annotation menu. 

2. Click the arrow next to  , and choose the color of the sticky note.

3. Click the location where you want to add the sticky note, and enter your comments.
The annotation is saved automatically.

4. To change the color of the sticky note, select the note and repeat step 2.

5. To edit the note, select it and click  > Edit, and make the necessary changes.

6. To move the note, drag it to the desired location.

7. To remove the note, select it and click  > Delete from within the editor or from the annotation management pane. 

Search and filter annotations
Use the annotations pane to view all annotations in a file. Search and filter the annotations list to locate a particular annotation.
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Tip: Click  to reduce and click  to restore the right pane.

1. To search for the comments by a particular reviewer or text contained in a sticky note comment, in the Search box in the 
Annotations pane, start typing the desired string.
The list is filtered according to the matching results.

2. To filter the list by annotation type:

a.
Click  and make sure that Types is selected.

b. Select or clear the desired annotation type(s).
The display is updated dynamically.

c. Click Clear to clear the filters.

3. To filter the list by reviewer:

a.
Click  and make sure that Users is selected.

b. Select or clear the desired reviewer(s).
The display is updated dynamically.

c. Click Clear to clear the filters.

Share annotations
Share annotations that you've made on a file with other workspace members.

Tip: To share annotations with anyone who is not a workspace member, send a copy of the file and include annotations (see 
Send a protected file).

1. In the Workspaces Viewer, click  > Share annotations . 

2. In the To box, begin typing recipients email addresses.

The autocomplete feature suggests matches as you type. Choose to add individual users (by email address), distribution 
list, or an Active Directory group (if your Organization’s Workspaces server is connected to an Active Directory server).

Tip: Click Add all permitted members to add all permitted workspace members.

3. In the Subject box, change the subject if desired.

4. In the message box, type a message, if desired.

5. Click Send.
Authorized recipients can view the file by tapping on the link in the received email.
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Sending files

Send protected files from the Workspaces folder or via Microsoft Outlook.

Send a protected file
This task describes how to protect and send any file located in the Workspaces Folder or on the same volume as the Workspaces 
Folder to any email address. Sending a file creates a copy of the file which can then be managed in your Sent items, which is 
accessible via Workspaces mobile or web applications. You can also send a copy of a file from the Workspaces viewer. Sending a 
file in this way shares a copy of the workspace file with recipients.

Before you begin: To send a copy of a file, you must be defined in your oganization with an "Exchange sender" role, and your 
permissions for the file must be set to "full access" and no watermark.

1. Do one of the following:

• Right-click the file that you want to send, and select Workspaces > Send a copy.

•
In the Workspaces Viewer, click  > Send a copy .

2. In the To box, begin typing recipients email addresses.
The autocomplete feature suggests matches as you type. Choose to add individual users (by email address), distribution 
list, or an Active Directory group (if your Organization’s Workspaces server is connected to an Active Directory server).

3. In the Subject box, change the subject if desired.

4. In the message box, type a message, if desired.

5. Click Settings.

6. If the Require recipients to sign in check box is displayed, do one of the following:

• To ensure that recipients sign in to access the file, select the Require recipients to sign in check box.

• To allow recipients to access the file without signing in, clear the Require recipients to sign in check box.

Note: For more information on this feature, see About requiring recipient sign in.

7. If you want to share annotations with the file, click Include annotations.

8. If you want to allow recipients to work on the file(s) that you are sending, including uploading a new version, click Enable 
collaboration.

For more information on collaboration, see About collaboration.

9. In the Permission list, select the desired permissions from the drop-down list:
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Note: The permissions available and their defaults depend on what your organization administrator has set for your 
organization. You can change the default recipient permissions as desired for every file you send.

• Full access (not tracked): Recipients can download an original or encrypted version, edit, copy-paste, and print.

• Advanced Rights Management: Download protected, edit, print, copy: Recipients can download an encrypted 
version, edit, copy-paste, and print.

• Advanced Rights Management: Download protected, edit, print: Recipients can view, download an encrypted 
version, edit, and print.

• Advanced Rights Management: Download protected, & edit: Recipients can view, download an encrypted 
version, and edit.

• Advanced Rights Management: Download protected, & print: Recipients can view, download an encrypted 
version, and print.

• Advanced Rights Management: Download protected: View: Recipients can view and download an encrypted 
version.

• Online only: View & print: Recipients can view files in the online viewer and print.

• Online only: View: Recipients can view files in the online viewer only.

• Online only: Spotlight view: Recipients can view files in the online viewer in spotlight view only. In spotlight view, 
text is visible only in the region of the pointer; the rest of the text is obscured.

10. In the Watermark list, set whether the file is displayed with a watermark.

Note: When user permissions are set to Full access, watermarks are only displayed on PDF files.

11. In the File expiration list, set the time when the file will no longer be accessible by the recipients. Select a specific date, a 
time period from the list, or never. If you select Specific date, choose the desired date from the calendar.

12. In the Allow access to list, select who can access the file:

• Everyone: Everyone can access the file.

• Anyone within recipient’s domain: The recipient, and anyone else who signs in with an email in the same 
domain as the recipient, can access the file.

• Recipients only: Only the recipients of the email can access the file.

13. Click Send.
A confirmation message appears.

14. Click Close.
The file is sent.
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Sharing files via Outlook
Configure Workspaces for Microsoft Outlook to protect sent files with Workspaces, and set and manage permissions, even after 
sending.

Before you begin: ensure that the plugin is enabled in the Preferences window. See Enable plugins.

The first time you open Microsoft Outlook, the Workspaces wizard prompts you to configure the plugin. Thereafter, you can 
change your settings via the Workspaces plugin for Outlook window Settings tab accessed from the Workspaces ribbon.

Configure Workspaces for Microsoft Outlook
Set when to protect your attachments with Workspaces.

1. In Microsoft Outlook, access the Workspaces ribbon.

2. Click Settings and access the Settings tab and choose one of the following:

Select: To:

For every mail Protect all attachments with Workspaces automatically.

Your attachments are protected using your organization's default permissions 
unless you choose different security settings before sending the mail.

Only when I click 'Protect 
attachments'

Protect attachments with Workspaces only when you click Protect 
attachments in the email.

Your attachments are protected using your organization's default permissions 
unless you choose different security settings before sending the mail.

Ask me before sending Be prompted to decide whether or not to protect your attachments per email. 
Select when to be prompted:

• Select Always to be prompted every time you click Send when you 
have not chosen different security settings.

• Select Only when and Sending attachments larger than and enter 
the desired file size in MB to be prompted only when sending files 
larger than the specified size and when you have not chosen different 
security settings.

• Select Only when and Sending to addresses outside my email 
domain to be prompted only when sending files to anyone outside 
your email domain and when you have not chosen different security 
settings.
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3. Click OK.

Send smaller files
Use this method if sending files of up to 25MB. You can customize permissions and security settings on a per-email basis. For 
future emails, the permissions and settings return to your organization’s default settings.

1. Open a new email and enter a recipient and attach a file or files.

Depending on your plugin settings, the Set security for this email panel may appear at the side of the mail.

Tip: If it does not appear, click Protect Attachments  to display the panel.

Note: The options available in the Set security for this email panel depend on your organization's Workspaces Mode 
configuration.

2. Do one of the following:

• If you wish to protect your attachments with Workspaces and want to change the security permissions, perform 
steps 3-9, below.

• If you do not wish to change the default settings, click Send now.

• If you set to be asked before sending and you do not wish to protect your attachments with Workspaces, click 
Send Unprotected when prompted.

• If you set to be asked before sending and you want to protect your attachments with Workspaces with the default 
settings, click Send Protected when prompted.

• If you set to be asked before sending and you want to protect your attachments with Workspaces and want to 
change the security permissions, click Set permissions when prompted and perform steps 3-9, below.

3. If available, select Protect Attachments to ensure that your attachments are protected with Workspaces.

4. Select Require recipients to sign in to ensure recipients sign in to Workspaces to access the file.

Note: If you do not select this option, recipients have full access (not tracked) and can download an original or encrypted 
version, edit, copy-paste, and print. For more information, see About requiring recipient sign in.

5. If you require recipients to sign in, in the Permission list, select the desired permissions:

• Full access (not tracked): Recipients can download an original or encrypted version, edit, copy-paste, and print.

• Advanced Rights Management: Download protected, edit, print, copy: Recipients can download an encrypted 
version, edit, copy-paste, and print.

• Advanced Rights Management: Download protected, edit, print: Recipients can view, download an encrypted 
version, edit, and print.

• Advanced Rights Management: Download protected, & edit: Recipients can view, download an encrypted 
version, and edit.
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• Advanced Rights Management: Download protected, & print: Recipients can view, download an encrypted 
version, and print.

• Advanced Rights Management: Download protected: View: Recipients can view and download an encrypted 
version.

• Online only: View &print: Recipients can view files in the online viewer and print.

• Online only: View: Recipients can view files in the online viewer only.

• Online only: Spotlight view: Recipients can view files in the online viewer in spotlight view only. In spotlight view, 
text is visible only in the region of the pointer; the rest of the text is obscured.

6. If you require recipients to sign in, in the Watermark list, set whether or not the file is displayed with a watermark.

Note: When permissions are set to Full access, watermarks are only displayed on PDF files.

7. If you require recipients to sign in, in the File expiration list, set the time when the file will no longer be accessible by the 
recipients. Select a specific date, a time period from the list, or never. If you select Specific date, choose the desired date 
from the calendar.

8. If you require recipients to sign in, in the Allow access to list, select who can access the file:

• Everyone: Everyone can access the file.

• Recipient’s email domain: The recipient, and anyone else who signs in with an email in the same domain as the 
recipient, can access the file.

• Recipients only: Only the recipients of the email can access the file.

9. If you want to allow recipients to work on the file(s) that you are sending, including uploading a new version, click Enable 
collaboration.

10. Click Send.

Send larger files
This feature is only available if enabled by your organization administrator. When enabled, use this method to attach, protect, 
and share files of over 25MB.

1. Open a new email and enter a recipient.

2. In the Message tab in your mail editor toolbar, click Attach Large Files . 

3. Browse to and select your large file.

4. Change the default email security permissions if desired. For more information, see Sending smaller files.

5. Click Send.
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About collaboration
Collaborate on files you send via Microsoft Outlook with Workspaces for Windows.

When sharing files, click Enable collaboration to collaborate with others. Your recipients can edit the file (if granted the 
necessary permissions) and share the new version with all recipients, and you can monitor activity on sent files by opening the 
File activity panel in Outlook.

After you click Send, your recipients can collaborate on the file in the following ways:

• Annotate and edit the file online with the online viewer or in Office online

• Download the file and make changes locally, and then attach and protect the file in a reply to the original message; the 
changes are saved to Workspaces

• Upload a new version to the received file in their Workspaces Web Application Inbox

You can collaborate on the file in the following ways:

• Add recipients to the sent file via Workspaces Web Application, which means that you are expanding the group of 
people who can work on the file.

• Create a new email with the same attachment in Outlook or send a copy of the file via Workspaces Web Application to 
create a separate version of the file for collaboration with a different person or group of people.

Any activity on the file appears in the Workspaces File Activities panel for the selected email. Use the context menus to 
download or view the latest version of the file.

Tip: For more information on how collaboration is handled in Workspaces Web Application, refer to the Workspaces Web 
Application User Guide.

Collaborate on files
This task describes the workflow for collaborating on shared files. Follow the instructions to send back an edited shared file via 
Microsoft Outlook that was sent to you with collaboration enabled.

1. Click Reply or Reply All to the email you received with the shared file.

2. Attach your updated version of the file. Ensure that the filename is identical to that of the original shared file.

3. Protect the attachment with Workspaces. For instructions, refer to Send smaller files if necessary.

4. Click Send.

The file is uploaded to Workspaces as a new version of the original shared file. Your recipients can access the file and 
collaborate on the file.

For more information on collaboration, see About collaboration.

Track activities on the file, for more information see Track collaboration.
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Track collaboration
Open the Workspaces File Activities panel to track actions performed on files you have sent with collaboration enabled.

1. In Outlook, select the mail that you have sent or received where collaboration is enabled.

2. In the Home ribbon, click File Activities.
The File Activities panel appears with details of activities performed on the file.

3. To view the latest version of the file, click View under any of the file activities.

4. To download the latest version of the file, click Download under any of the file activities.

5. Where the list of activities is clipped, for example where there is more than one attachment, click More to view all 
activities.
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Contacting Support

If you encounter a problem, you can:

• Access the Help Center to browse the Workspaces Support portal for help

• Report an issue to generate log files to send to Support

Access the Help Center
Right-click the Workspaces icon in the taskbar, and select Help > Help Center.
The online support portal opens, where you can browse for help.

Report an issue
1. Right-click the Workspaces icon in the taskbar, and select Help > Report an issue.

An email opens addressed to Workspaces Support.

2. Verify that your correct email address is displayed.

3. Enter a description of the issue in the Description box.

4. Click Choose file to add screenshots of up to 3MB per file, as desired.

5. Do one of the following:

• Click Send to generate log files and to open a mail in your default mail application to report the issue. Send the 
mail in the usual way.

• Click Save to generate log files and save them for later. Save the log files in the usual way.
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About user roles, sharing, 
collaboration and permissions

Security, sharing, collaboration, and recipient sign in within BlackBerry Workspaces are defined by user roles and permissions. 
User roles and permissions are set for each workspace group.

About workspace members
Workspace members can be added individually and assigned a role and permission set, or organized into groups with a group 
role and permission set. Members can access all workspace folders and files unless your organization's BlackBerry Workspaces 
administrator specifies otherwise. Members are workspace-specific and their defined permissions in one workspace does not 
grant them access to other workspaces or their folders and files.

About roles
Use roles to determine user management capabilities within your workspaces. You define roles when you create a workspace, 
and you can change or remove roles later by editing the group.

There are four standard roles with pre-defined capabilities. Organizations that are configured for creating custom roles can offer 
additional roles with unique capabilities.

The standard roles are described here:

Administrators

Workspace administrators have full control over the workspace and its folders and files (upload, download, move, delete, and so 
on). Administrators can also manage workspace groups and users. By default, the workspace creator is added to the 
Administrators group.

Group Manager

Workspace administrators can add or define any group member as group manager. Managers can add and remove members to 
the group, but do not have any additional capabilities.

Contributors

Contributors perform the following actions:
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• Folder level: Add and delete folders, move files across folders. Full access, download protected, copy link, move, and 
rename folders.

• File level: Add and remove files, view online, download originals for files uploads, print, download protected versions, 
upload new versions, view versions and annotations, copy link, move, rename.

Visitors

Visitors can access workspace files depending on their permissions. Visitors cannot upload files to workspaces. Default file 
permissions for visitors are set by your organization administrator. Define users as visitors when creating a group.

About permissions
Use permissions to define user access rights for workspace files. A number of permission sets are available, depending on what 
has been set by your organization BlackBerry Workspaces administrator, and according to your organization's defined 
enterprise mode.

Available permission sets

Full access

Users with full access permissions can perform all actions in BlackBerry Workspaces.

Advanced rights management

The Advanced Rights Management permission sets are available for BlackBerry Workspaces Enterprise ES Mode and 
BlackBerry Workspaces Enterprise ES (Restrict Full Access) Mode only.

The following table details the available permissions for each advanced rights management permission level.

 Full access Download 
Protected

View online Copy Edit Print Programmatic 
access 

Download 
protected, 
edit, copy & 
print

- Yes Yes Yes Yes Yes -

Download 
protected, 
edit & print

- Yes Yes - Yes Yes -
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Download 
protected & 
edit

- Yes Yes - Yes - -

Download 
protected & 
print

- Yes Yes - - Yes -

Download 
protected

- Yes Yes - - - -

Online only

 Full access Download 
Protected

View online Copy Edit Print Programma
tic access 

View & print - - Yes - - Yes -

View - - Yes - - - -

Spotlight 
view

- - Spotlight 
view only 
(blurred 
outside of 
subject area 
to block 
over the 
shoulder 
viewing)

- - - -

No access - - - - - - -

About customizing access to folders or files
Entities (individuals, groups, or members of an email domain) can access workspace folders and files, based on the permissions 
you selected.

Permissions can be adjusted by applying different permission levels. When adding new entities, you can also select if you want 
to give them access to all workspace folders and subfolders or to add them only to the selected item and any subitems that 
inherit permissions.

If you choose to allow only certain entities to access a certain folder or file, this creates broken inheritance with the parent 

workspace or folder, and the item icon is marked with a broken chain; .
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If you choose to only give permissions to a folder and subitems that inherit permissions, this will break inheritance for the folder, 
and for all child items as well. All subfolders or files under that folder, will inherit the permissions set for that folder.

If you choose to give permissions to a folder and all subitems, this will override broken inheritance for the folder all subfolders 
and child items.

About requiring recipient sign in
Organizations that enable users to share files without requiring recipient sign in (simple sharing) can choose whether or not to 
give users the option to require their recipients to sign in to access sent files. If your organization has simple sharing enabled 
and has given you the option to choose whether or not your recipients are required to sign in, the Require recipients to sign in 
check box is displayed in the Send a Protected File and Workspaces Email Security windows.

Select Require recipients to sign in to require recipients of files sent by Workspaces to sign in to Workspaces to receive the file. 
When the checkbox is selected, the Manage recipient permissions link is displayed in the Send a Protected File window. Click 
Manage recipient permissions to set the recipient access permissions to the file.

Clear the Require recipients to sign in checkbox to waive the need for recipients to access the file without signing in.

When cleared, recipients are sent a link giving them access to the original version of the sent file. They can download the file 
and there is no tracking or restrictions on their use of the file. In this case, access to the file is tracked by Workspaces according 
to the user email when the user is signed in to Workspaces; or under the alias "anonymous" if the user is not authenticated.

Once the file has been shared without requiring recipient sign in, you cannot change the recipient permissions to the file. 
Should you need to revoke recipient access to the file, you must delete the file from your sent items via the Workspaces Web 
Application.
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NOT ALLOW THE EXCLUSION OR LIMITATION OF IMPLIED WARRANTIES AND CONDITIONS. TO THE EXTENT PERMITTED BY 
LAW, ANY IMPLIED WARRANTIES OR CONDITIONS RELATING TO THE DOCUMENTATION TO THE EXTENT THEY CANNOT BE 
EXCLUDED AS SET OUT ABOVE, BUT CAN BE LIMITED, ARE HEREBY LIMITED TO NINETY (90) DAYS FROM THE DATE YOU 
FIRST ACQUIRED THE DOCUMENTATION OR THE ITEM THAT IS THE SUBJECT OF THE CLAIM.

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW IN YOUR JURISDICTION, IN NO EVENT SHALL BLACKBERRY 
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PORTION THEREOF OR OF ANY AIRTIME SERVICES, COST OF SUBSTITUTE GOODS, COSTS OF COVER, FACILITIES OR 
SERVICES, COST OF CAPITAL, OR OTHER SIMILAR PECUNIARY LOSSES, WHETHER OR NOT SUCH DAMAGES WERE 
FORESEEN OR UNFORESEEN, AND EVEN IF BLACKBERRY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW IN YOUR JURISDICTION, BLACKBERRY SHALL HAVE NO 
OTHER OBLIGATION, DUTY, OR LIABILITY WHATSOEVER IN CONTRACT, TORT, OR OTHERWISE TO YOU INCLUDING ANY 
LIABILITY FOR NEGLIGENCE OR STRICT LIABILITY.

THE LIMITATIONS, EXCLUSIONS, AND DISCLAIMERS HEREIN SHALL APPLY: (A) IRRESPECTIVE OF THE NATURE OF THE 
CAUSE OF ACTION, DEMAND, OR ACTION BY YOU INCLUDING BUT NOT LIMITED TO BREACH OF CONTRACT, NEGLIGENCE, 
TORT, STRICT LIABILITY OR ANY OTHER LEGAL THEORY AND SHALL SURVIVE A FUNDAMENTAL BREACH OR BREACHES 
OR THE FAILURE OF THE ESSENTIAL PURPOSE OF THIS AGREEMENT OR OF ANY REMEDY CONTAINED HEREIN; AND (B) 
TO BLACKBERRY AND ITS AFFILIATED COMPANIES, THEIR SUCCESSORS, ASSIGNS, AGENTS, SUPPLIERS (INCLUDING 
AIRTIME SERVICE PROVIDERS), AUTHORIZED BLACKBERRY DISTRIBUTORS (ALSO INCLUDING AIRTIME SERVICE 
PROVIDERS) AND THEIR RESPECTIVE DIRECTORS, EMPLOYEES, AND INDEPENDENT CONTRACTORS.

IN ADDITION TO THE LIMITATIONS AND EXCLUSIONS SET OUT ABOVE, IN NO EVENT SHALL ANY DIRECTOR, EMPLOYEE, 
AGENT, DISTRIBUTOR, SUPPLIER, INDEPENDENT CONTRACTOR OF BLACKBERRY OR ANY AFFILIATES OF BLACKBERRY 
HAVE ANY LIABILITY ARISING FROM OR RELATED TO THE DOCUMENTATION.
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airtime service provider has agreed to support all of their features. Some airtime service providers might not offer Internet 
browsing functionality with a subscription to the BlackBerry® Internet Service. Check with your service provider for availability, 
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products and services may require one or more patent, trademark, copyright, or other licenses in order to avoid infringement or 
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Third Party Products and Services until all necessary licenses have been acquired. Any Third Party Products and Services that 
are provided with BlackBerry's products and services are provided as a convenience to you and are provided "AS IS" with no 
express or implied conditions, endorsements, guarantees, representations, or warranties of any kind by BlackBerry and 
BlackBerry assumes no liability whatsoever, in relation thereto. Your use of Third Party Products and Services shall be governed 
by and subject to you agreeing to the terms of separate licenses and other agreements applicable thereto with third parties, 
except to the extent expressly covered by a license or other agreement with BlackBerry.
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